ThemeShaper Forums » Thematic

[closed]

Tabbed links to pages not working

(9 posts)
  • Started 3 years ago by leicesterweb
  • Latest reply from lastraw
  • This topic is not resolved
  1. leicesterweb
    Member

    Hi all,

    I am building a new Wordpress site at http://www.kellyhainsworth.com/new/.

    I have nine pages which I want in my tabbed navigation - so far it's been a breeze.

    However, when I switch permalinks on, i get an error when I click on 'Reflexology' and it goes to http://www.kellyhainsworth.com/new/reflexology/. How can I get the tabs to go to the correct URls - as they do now - but display the content?

    I want http://www.kellyhainsworth.com/new/reflexology/ to display http://www.kellyhainsworth.com/new/?page_id=5 and the same for the rest of the tabbed options. Could it be my .htaccess or another reason?

    Posted 3 years ago #
  2. What permalink setting are you using?

    Posted 3 years ago #
  3. leicesterweb
    Member

    Thanks for the reply.

    I am currently using /pagename/, but I have tried a few including /%year%/%monthnum%/%postname%/ and they do not seem to work either. I Googled the issue and, having seen it here http://forums.digitalpoint.com/showthread.php?t=497966,
    posted the below in my .htaccess, but that's not worked either:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I am truly stumped by this one - any advice gratefully receievd.

    Posted 3 years ago #
  4. I always use /%category%/%postname% and don't have any problems.

    Have you tried using the custom menu settings (on the left under appearances)?

    Posted 3 years ago #
  5. leicesterweb
    Member

    Yep, just tried /%category%/%postname% and still no joy :o(

    Also I tried creating a new menu and adding a category and also all the pages - but it still directs to error pages for all the tabs.

    Still mystified by this one as the default permalinks work fine...

    Posted 3 years ago #
  6. leicesterweb
    Member

    Could it be that my .htaccess is the issue - it has a User Permission setting of 000?

    I cannot think of anything else I am doing which would cause the problem :o(

    Posted 3 years ago #
  7. Go ahead and change it to find out—you can always change it back.

    Posted 3 years ago #
  8. leicesterweb
    Member

    My host states I cannot have Wordpress SEO-friendly URLs onmy Windows hosting account - and that I should switch to Linux. There's not much work involved in doing this, but I wanted to ask whether you have experienced this before - is there really no way of doing this using Wordpress on Windows?

    Posted 3 years ago #
  9. Who is your host?

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.