ThemeShaper Forums » Thematic

[closed]

Thematic 0.9.6-β-06 - Subsidiary Asides Missing

(6 posts)
  • Started 4 years ago by freedimensional
  • Latest reply from Chris
  • This topic is not resolved
  1. Evening all,

    I'm using the latest SVN copy of Thematic as the basis of my Power Blog child theme.
    Since upgrading yesterday, my three subsidiary asides are no longer being rendered.

    The widgets ARE being registered because I can see them in my Widget Settings.
    Switching to Thematic purely, clears the problem, so something seems weird.

    Any committers out there, please can you look into this?

    Yours,
    Tom

    Posted 4 years ago #
  2. Hi,

    You could always downgrade back to the current release but thats no fun because the svn is way cooler.

    I'm not that familiar with that child theme but I'm guessing that it's functions.php hasn't been updated to match the changes to the new subsidiary widgets hook.

    Try searching the Power Blogs functions.php for each of these three hooks: widget_area_1st_subsidiary_aside widget_area_2nd_subsidiary_aside widget_area_3rd_subsidiary_aside and replace them each with widget_area_subsidiaries. This is a best guess on my part.

    Look at the diffs in r585 for more info. If your still having problems Chris will know the best way to address this.

    -Gene

    Posted 4 years ago #
  3. Hi,

    tested Thematic Power Blog against the current SVN version without any problem. Widgets are registered against the subsidiary areas and will display on my blog.

    The system to create the widget areas for Thematic completely changed compared to 0.9.5.1, but it still works with all child themes.

    In addition to my first test I tested the upgrade itself. Copying 0.9.5.1 and the current SVN version back and forth .. and .. my blog is still working and displays the subsidiary areas with its widgets.

    Chris

    Posted 4 years ago #
  4. Not that guesswork has helped so far but...

    What version of WP have you got installed? Just wondering because there were a fair amount of changes to the widgets API and bugs between 2.7.1 and 2.8.4

    Have you tried dragging the widgets out and adding them again?

    Have you tried resetting widgets using thematics options page in the admin?
    *be warned this will erase the contents of even the inactive widgets and you'll loose any widget settings

    Posted 4 years ago #
  5. Hi both,

    I'm using WordPress 2.9.1 - and I've followed your advice but to no avail.
    I have made some changes to power blog's functions.php that may be causing this.

    Are you able to send me a new .zip for power blog's theme files?
    I don't have it archived following it's purchase.

    Tom

    Posted 4 years ago #
  6. Hi Tom,

    send an email to chris (at) wupperpiraten (dot) de

    Chris

    Posted 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.