ThemeShaper Forums » Development Talk

[closed]

Thematic 0.9.7.6 is online - Important Release Notes

(35 posts)
  • Started 4 years ago by Chris
  • Latest reply from helgatheviking
  1. Hi,

    please make sure that you include the following lines into your functions.php:

    define('THEMATIC_COMPATIBLE_BODY_CLASS', true);
    define('THEMATIC_COMPATIBLE_POST_CLASS', true);
    define('THEMATIC_COMPATIBLE_COMMENT_FORM', true);
    define('THEMATIC_COMPATIBLE_FEEDLINKS', true);

    Chris

    Posted 4 years ago #
  2. yeaaaahhh!! thank you Chris and Gene for all your work! You guys rock... and so does Thematic!

    Posted 4 years ago #
  3. Thanks Chris for your work on this new release. The new childtheme overwrite functions are really cool.

    By the way, you started work on that thematic Plugin way back when.. any news about that ? :)

    Posted 4 years ago #
  4. JC
    Member

    Thank you guys ! thank you for all the tough work and the beautiful code, I really enjoy creating wordpress themes using Thematic !

    Posted 4 years ago #
  5. Thompson
    Member

    Awesome! Rock on Chris!

    Posted 4 years ago #
  6. An upgrade is awesome but with WordPress's newest version, a ONE CLICK theme upgrade is awesome on toast!

    Thanks muchly!

    Posted 4 years ago #
  7. Yay! Thanks so much.

    Posted 4 years ago #
  8. Thanks so much, and my small problem with the menu in the child theme was easily updated too!

    Posted 4 years ago #
  9. Download still has 0.9.6.2

    Posted 4 years ago #
  10. Hi,

    @dyrer: Will send a note to Ian. His blog still links directly to v.0.9.6.2. You can find the latest version on http://wordpress.org/extend/themes/thematic

    @cristi: This is still sitting on my local machine, waiting for some final work. I'm still not clear, if this will end as a plugin or as a extension integrated into Thematic.

    Chris

    Posted 4 years ago #
  11. I replaced the entire old Thematic theme folder I was using (0.9.6.2) with the new 0.9.7.7 folder and everything worked, except ... my access menu disappeared.

    I had made the following change to access in my child theme functions.php, but that's it.

    Is there something else I need to do to ensure my child theme is upwardly compatible?

    // Remove the action creating the access menu
    function remove_access() {
    	remove_action('thematic_header','thematic_access',9);
    }
    add_action('init', 'remove_access');
    
    // Rebuild the access menu
    function childtheme_access() { ?>
    	<div id="access">
    		<div class="skip-link">
    			<a href="#content" title="<?php _e('Skip navigation to the content', 'thematic'); ?>"><?php _e('Skip to content', 'thematic'); ?></a>
    		</div>
    		<?php wp_page_menu('sort_column=menu_order') ?>
    		<div id="access-search">
    			<form id="searchform" method="get" action="<?php bloginfo('home') ?>">
    				<div>
    					<input id="s" name="s" type="text" value="<?php echo wp_specialchars(stripslashes($_GET['s']), true) ?>" size="20" tabindex="1" />
    					<input id="searchsubmit" name="searchsubmit" type="submit" value="<?php _e('Search', 'thematic') ?>" tabindex="2" />
    				</div>
    			</form>
    		</div>
    	</div><!-- #access -->
    <?php }
    
    add_action('thematic_header','childtheme_access',9);
    Posted 4 years ago #
  12. i believe you have to echo the menu

    '
    echo thematic_add_menuclass(wp_page_menu(thematic_page_menu_args()));
    '

    see http://developing.thematic4you.com/2010/04/breaking-things-to-fix-others/

    Posted 4 years ago #
  13. Bingo.

    Thank you, thank you!

    I will go back to the threads that referenced that old menu code and link to this thread.

    Posted 4 years ago #
  14. @ jcollier - thank you for pitching in and keeping people informed :)

    Posted 4 years ago #
  15. krackpot
    Member


    define('THEMATIC_COMPATIBLE_BODY_CLASS', true);
    define('THEMATIC_COMPATIBLE_POST_CLASS', true);
    define('THEMATIC_COMPATIBLE_COMMENT_FORM', true);
    define('THEMATIC_COMPATIBLE_FEEDLINKS', true);

    Do we put these lines in the Thematic functions.php or our Thematic Child Theme's function.php?

    Posted 4 years ago #
  16. In the Child Theme's functions.php

    Posted 4 years ago #
  17. Also to add a home link to your navigation use this code and disregard the snippet included with the sample child theme that was included versions up to 0.9.7.7.

    function childtheme_menu_args($args) {
        $args['show_home']  = 'Home';
    
    	return $args;
    }
    add_filter('wp_page_menu_args','childtheme_menu_args', 20);

    *priority 20 is necessary

    Posted 4 years ago #
  18. krackpot
    Member

    Thanks for the clarity :)
    The "Home link" to the navigation menu is very useful as well.

    For those who want to use the official 3.0 menus (I found it on some site, Archon Digital):

    function change_menu_type() {
    return 'wp_nav_menu';
    }
    add_filter( 'thematic_menu_type', 'change_menu_type' );

    I hope this helps, since I couldn't find a way to do this in the Thematic documentation.

    Posted 4 years ago #
  19. Hi All -

    First... big thanks to Chris and Gene on the new version. Much appreciated.

    General Questions:

    1. What new features does 9.7.7 bring to table?

    2. What do the following compatibles do?
    define('THEMATIC_COMPATIBLE_BODY_CLASS', true);
    define('THEMATIC_COMPATIBLE_POST_CLASS', true);
    define('THEMATIC_COMPATIBLE_COMMENT_FORM', true);
    define('THEMATIC_COMPATIBLE_FEEDLINKS', true);

    3. Will #2 and the following be required for all child functions files going forward?
    echo thematic_add_menuclass(wp_page_menu(thematic_page_menu_args()));

    4. Are there any other required or recommended includes for child functions files?

    Thanks -
    Scott

    Posted 4 years ago #
  20. You wont see the release notes if you first see the upgrade as part of WPs update checks !!

    0.9.7.7 still has the old code snippet in the thematicchildsampletheme even though its commented out

    Posted 4 years ago #
  21. @Scott

    1. is detailed in the changelog.html of the new version
    2. These are also noted in the changelog. They were requirements for inclusion in the WP Theme Repo. Those constants when defined tell Thematic to use it's functions instead of the core WP functions required by the new WP Theme Review Guidelines.
    I am familiar with your child themes and they will break on body classes alone, if you do not define those constants in every install that you upgrade.
    3. That is entirely up to whether you want to continue using the Thematic functions or if you prefer the WP core set for each given area of functionality.
    4. At this time the only official code snippet recommendations are posted in this thread

    The biggest issues reported by forum members so far are:
    * the class / stylesheet issues related to the constants mention above
    * prior navigation menu customizations breaking with the new version
    * the widgets being cast into the inactive bin

    I would suggest you test before pushing an upgrade to a live client site. I also suggest using a maintenance page or maintenance plugin solution while upgrading critical sites before pushing the upgrade.

    @DavyB Thanks, we'll be working on that.

    Posted 4 years ago #
  22. Isn't the title of this thread now wrong since 0.9.7.7 is online :p

    Posted 4 years ago #
  23. As far as my texting shows the widgets disappearing issue occurs only if you switch themes. This is a normal WordPress behavior. If you're interested in backing up your widgets locations before switching themes or upgrading:

    Try using this plugin: http://wordpress.org/extend/plugins/widget-saver/

    Posted 4 years ago #
  24. Please excuse my "newbie" question. I'm unsure where to find where to insert this code. Is this on the back end of Wordpress or do I need to dig into my web host files?

    ***edited*** I was doing it the trial&error method and figured it out. Fixed exactly what I needed. TYTYTY!

    Posted 4 years ago #
  25. illustrata
    Member

    @arwsgirl, could you tell the other non-ninjas among us where you placed the code to get it to work? On my third trial&error with no success yet... ;)

    Posted 4 years ago #
  26. @illustrata and other non-ninjas

    see question in permalink (one of those # links)

    http://forums.themeshaper.com/topic/thematic-0976-is-online-important-release-notes#post-16312
    and its immediate answer
    http://forums.themeshaper.com/topic/thematic-0976-is-online-important-release-notes#post-16320

    Posted 4 years ago #
  27. Sixstring
    Member

    @helgatheviking, where do I put the 'echo' line of code?

    @ALL My second level menu items have dissapeared after upgrading to 0.9.7.7. Does anyone have an idea how to fix this?

    Posted 3 years ago #
  28. I am using Thematic Options 2.0 but since this is a child theme i am using the Thematic 0.9.7.7. So i still need to add that code to childs functions if i want to use the Thematic functions instead of the built in WP ones?

    Or has this been fixed already and added to childs functions?

    But i thought it said something about the WP functions taking prority over thematic childs functions or something like that and we have to add that code to childs funtions.php.

    Parents, children. grandchildren..its starting to make sense now but that one went over my head and i am not sure if i need to add it or not. If it is not there i guess i have been using WP functions?

    What is the difference then? Ah, dont answer that. I am a n00b and it will go over my head anyway.

    Posted 3 years ago #
  29. andyshine78
    Member

    Hi all I've just finished to upgrade to the new version and everything seems to work fine thanks to the new constants. I've only one simple question in my fucntion.php (childtheme) I have a function for filtering the body classes and pior to this version the filter was "body_class":

    and now I have changed with "thematic_body_class:

    add_filter('thematic_body_class','repl_wp');

    Is it right? Everything seems to work fine but I just wanted a confirm.

    I write you here the full function:


    // Replace body class
    function repl_wp($c) {
    get_post_type();

    $attachment_gallery = attachment_gallery();
    if (is_attachment() && isset($attachment_gallery)) {
    return str_replace('single', 'attachment_gallery', $c);
    }
    else if( get_post_type() == 'video_works' ) {
    return str_replace('single', 'video_works', $c);
    }
    else {
    return $c;
    }
    }
    add_filter('thematic_body_class','repl_wp');

    Posted 3 years ago #
  30. One last one for those who need the old Thematic custom field activated page comments:

    Try:

    define('THEMATIC_COMPATIBLE_COMMENT_HANDLING', true);

    to restore the custom field activated page comments.

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.