ThemeShaper Forums » Development Talk

[closed]

Thematic 0.9.8 beta testers wanted

(14 posts)
  1. Ask not what Thematic can do for you... Ask what you can do for Thematic.

    We need beta testers! Here is where development updates to the next release will be voiced and open for discussion.

    For detailed bug reports please use the Thematic google code issues page.

    Posted 3 years ago #
  2. An a nutshell the last two commits r761 & r762 have provided custom Taxonomy and custom Post Support to Thematic's thematic_post_footer() and the functions called inside of it.

    Here are the latest changes.

    Here are the diff's on revision 762

    I have tested these changes over the last few days. I think it's ready but need some feedback. Please checkout the latest(currently r762) svn and test against your custom post types and custom taxonomies.

    This is a big rewrite of thematic_post_footer and it's associated functions. These changes may impact users who have overridden or filtered these functions. The translation files will also be impacted from these revisions. The rewrite has changed translated output to remove some punctuation and whitespace and possible added new strings for translation. As a result language files will need minor updates.
    At this point the revision needs a minimum WP version of 3.0 but some of the custom post functionality depends on WP 3.1. Namely the has_archive parameter of WP's register_post_type() which was introduced in 3.1.

    I'm going to list the bugs I have found here but if you find more I ask that you report them here:

    http://code.google.com/p/thematic/issues/list

    Known Bugs:

    • Testing against WP 3.0.x installs the Custom Post Type archives default to using the index.php so the thematic_page_title does not output "Archives: {$post_type->name}" WP 3.1 uses the archive.php and the thematic_page_title outputs as expected.
    • The custom post archive permalink uses query string instead of a rewrite safe permalink to provide compatibility to WP 3.0.x and because I haven't figured out how to get the proper permalink. Any Ideas?
    Posted 3 years ago #
    • Two more bugs I think are WordPress version 3.1 and earlier related and not necessarily caused by Thematic

    • If categories and/or post tags are assigned as taxonomies when registering a custom post type...
      Then the posts (of custom post type) don not get queried and displayed in the assigned category and tag archives
    • If a custom post type is assigned the taxonomy "category" and no categories are selected when publishing a post type,
      Then the postfooter will display "Uncategorized" without a link.
    Posted 3 years ago #
  3. gene- 0.9.8 is the latest in the SVN repo? it sounds like i should specifically be looking at custom types and type archives. i'll dig around a little.

    Posted 3 years ago #
  4. Yes it's currently at 0.9.8 r762

    I tested it with taxonomy support for multiple variations of taxonomy combinations and post type support for comments to see how the post footer display might break. This is the reason for the punctuation and spacing changes to translation strings. Things were much simpler with just cats and tags. Custom taxonomies + post_types greatly increased the complexity of communicating the post footer links.

    My tests used one custom post type and two custom taxonomies and using only two published posts.

    It would be nice try with a larger number of posts to test for pagination problems.

    I'd also like to see if anyone can test the overrides and filters for effectiveness and/or obvious problems.

    Posted 3 years ago #
  5. hi gene- i took a quick look at this today since my never-going-to-go-live portfolio theme already has a custom post type. last night i added some taxonomies to it and this morning i cranked out 12 dummy posts.

    so far it looks pretty good. i didn't find anything major. pagination works on the post-type archive page as does the post navigation (next post/previous post). hierarchal and non-hierarchal tags show up.

    one thing i think might be missing is a way to get back to say Portfolio type archive if you are at a Portfolio taxonomy archive

    Here is a sample post footer:

    Portfolio Tags: bacon | Genre: Fantasy | Writer: Jack Whyte | Leave a comment | Edit

    If you are at a Portfolio Post then the post footer looks like

    Browse the Portfolio Item archive. Portfolio Tags: bacon. Genre: Fantasy. Writer: Jack Whyte. Bookmark the permalink. Trackbacks are closed, but you can post a comment. Edit

    Oh and if you are the 'bacon' 'Portfolio Tag' archive then 'bacon' is repeated in the post footer. On regular posts I seem to recall an different footer that said 'Also posted in' or 'Also tagged in' and excluded the tag/cat of your current archive.

    That's all I've got so far- Hope it helps some.
    and the Portfolio Archive is there.

    Posted 3 years ago #
  6. Sweet Thanks. Much appreciated. Ah, I see. The regular posts get run through the cats meow and tag ur it functions. Maybe those could be broadened to cover tax_hierarchal and tax_non_hierarchal.

    Posted 3 years ago #
  7. I tested this tonight, and everything seemed to be working great with custom post types and taxonomies. I have two custom post types set up and two custom taxonomies. Here's what the post footers look like.

    City: West Des Moines. Service: Tattoo. Bookmark the permalink. Post a comment or leave a trackback: Trackback URL.

    I did have one problem though. I decided to test it live on a server with a custom menu and the id and class where removed from the menu ul. It's a pretty customized child theme, so it maybe something on my end.

    Posted 3 years ago #
  8. Hi Gene & Colleagues -

    Is this the link for the current build: http://developing.thematic4you.com/wp-content/plugins/download-monitor/download.php?id=1

    Between Chris' site, and the Google "Commit" list (http://code.google.com/p/thematic/people/list), I'm not sure where best to get the latest version and help test it. Please advise.

    You may add me as a "committer".

    - Scott

    Posted 3 years ago #
  9. @scott- currently this is still where to get the latest dev release:

    http://developing.thematic4you.com/thematic-development-release/

    Posted 3 years ago #
  10. cannobbio
    Member

    @sfrangos & @helgatheviking:
    http://developing.thematic4you.com/thematic-development-release/ is hosting r756
    Isn't the latest build (r762) @ http://thematic.googlecode.com/svn/trunk ?

    That's what I've always used...

    Posted 3 years ago #
  11. good point. the version at thematic4you is hailed as the latest "stable" dev release, while the google code must be more of the bleeding edge stuff. or chris has been busy and hasn't updated his site.

    Posted 3 years ago #
  12. I've always found the easiest way to get the latest version of Thematic is to open a terminal window and enter this.
    svn checkout http://thematic.googlecode.com/svn/trunk/ thematic-read-only

    Posted 3 years ago #
  13. I also have the latest version up and running on a live site. I figured out the issue I was having with the menu. When I updated the theme it kicked my custom menu out of the Primary Menu slot. I haven't noticed any other issues yet. www.tattoodesmoines.com

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.