ThemeShaper Forums » Thematic

[closed]

Thematic doesn't maintain styles in Archives Section :(

(4 posts)
  • Started 5 years ago by gracestanat
  • Latest reply from bconradt
  • This topic is resolved
  1. gracestanat
    Member

    Ian:

    First of all, awesome work! I am enjoying learning about WordPress and especially Child Themes based almost entirely on your work and online advice.

    In working on my Child Theme, I've noticed that Thematic does not maintain the text styles when you go into the Archive section (i.e., almost all the text just appears in body style, so there are no headings, etc.). Also, the pix are missing. At first I though this might be standard, but I've looked at other themes and they seem to maintain styling in the Archive section.

    How can I get the posts in my Archive to look as they do when they are posted? Thanks in advance!

    Posted 5 years ago #
  2. The archives are output using the_excerpt which strips formatting from your post and only shows the first 55 characters. It's the recommended way of outputting archives. Most good themes use it.

    That said, this plugin

    http://sparepencil.com/code/advanced-excerpt/

    will give you more control over the output.

    Let me know how it works out for you.

    Posted 5 years ago #
  3. gracestanat
    Member

    ok - thanks! i'm definitely still learning - i'll check it out!

    Posted 5 years ago #
  4. Just wanted to chime in and say thanks for this tidbit.

    I'm using the Evermore plug-in and was wondering why my archive page was styled differently. I like it a little better than the Advanced Excerpt plug-in so what I did was enable full posts for everything, that way Evermore can just manage it all.

    function childtheme_content($content) {
    	$content= 'full';
    	return $content;
    }
    add_filter('thematic_content', 'childtheme_content');
    Posted 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.