ThemeShaper Forums » Thematic

Thickbox won't work

(4 posts)
  • Started 5 years ago by imation256mb
  • Latest reply from imation256mb
  • This topic is not resolved

Tags:

  1. imation256mb
    Member

    Hi, I'm having trouble using thickbox on thematic. I've copypasted the thickbox.css in my style.css and I included thickbox-compressed.js but it won't work.

    http://merlejagdreisen.com/blog/ is the site, there is a small link("contact") in the footer under "Download" that should open thickbox.

    Note that this is my first attempt to use wordpress, so please be gentle. Also the site is long before completion.

    Do you have any idea why thickbox won't work?

    Thank you.

    Posted 5 years ago #
  2. amygail
    Member

    You're receiving this error

    Error: $ is not a function
    Source File: http://merlejagdreisen.com/blog/wp-content/themes/thematic/library/scripts/thickbox-compressed.js
    Line: 10

    This post should help...
    http://forums.themeshaper.com/topic/easyslider-and-thematic#post-5065

    Posted 5 years ago #
  3. imation256mb
    Member

    Thanks amygail, that worked.

    I'm having a different problem now, I can't open in the thickbox a page that's not a wordpress page.

    I now have two links under the download button:
    -one links to 'ungarn', which is a page of my blog, this link works fine.
    -the second one links to 'http://merlejagdreisen.com/contact.php' and does not work in thickbox, but it work if I open the link in a new tab.

    This is probably more related to wordpress (.htaccess maybe) than thematic.

    Posted 5 years ago #
  4. imation256mb
    Member

    I've solved the problem by creating a new page, setting to new page to link to "http://merlejagdreisen.com/contact.php" (with the page links to plugin).
    Then I set the link that opens the thickbox to link to the new page.

    But I'd still like to know why thickbox didn't open the page in the first place.

    Posted 5 years ago #

RSS feed for this topic

Reply

You must log in to post.