ThemeShaper Forums » Thematic

[closed]

top menu says home twice?

(4 posts)
  • Started 4 years ago by explinfin
  • Latest reply from em hr
  • This topic is not resolved
  1. I have set my site to go to a static page on the main page.

    I want when you click "Home" it to go to a page i have titled "home" but now it shows up on the top menu "Home, About, Home" and both "home's click through to the main page.

    How do i make the 2nd "home" go away?

    Also, how do I make it say "Blog" on the top beside the first "home" so that when they click there it goes to show my most recent posts like a regular blog?

    Thanks!

    Posted 4 years ago #
  2. Hi,

    This function will work with Thematic 0.9.6.2

    function child_menu_args($args) {
        $args ['show_home'] = 'Blog';
        return $args;
    }
    add_filter('wp_page_menu_args','child_menu_args');

    but future versions of Thematic will require you to set the echo parameter to false. The following function will work with future versions of Thematic released after 0.9.6.2

    function child_menu_args($args) {
        $args ['show_home'] = 'Blog';
        $args ['echo'] = false;
    
        return $args;
    }
    add_filter('wp_page_menu_args','child_menu_args');

    See http://developing.thematic4you.com/2010/04/breaking-things-to-fix-others/ for more info

    -Gene

    Posted 4 years ago #
  3. wow i have no idea what any of that means. :(

    Posted 4 years ago #
  4. That's OK try and copy this code and paste it into your child theme's functions.php

    function child_menu_args($args) {
        $args ['show_home'] = 'Blog';
        return $args;
    }
    add_filter('wp_page_menu_args','child_menu_args');
    Posted 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.