ThemeShaper Forums » Thematic

[closed]

Using WP Page Numbers with thematic

(4 posts)
  • Started 9 years ago by JLocke
  • Latest reply from Bluesky
  • This topic is not a support question
  1. Hey,

    I was trying to find how to use the plug-in "WP Page Numbers" with thematic and I found an older post with the explanation:
    http://forums.themeshaper.com/topic/how-to-remove-older-and-newer-posts-links#post-9408

    I figured I'd just sum it up and give it a better title, so anyone who happens to be looking for this info can find it easier.

    First, install "WP Page Numbers".

    Add this to your functions.php

    // Action to create the new below navigation
    function childtheme_nav_below() {
    		if (is_single()) { ?>
    
    			<div id="nav-below" class="navigation">
    				<div class="nav-previous"><?php thematic_previous_post_link() ?></div>
    				<div class="nav-next"><?php thematic_next_post_link() ?></div>
    			</div>
    
    <?php
    		} else { ?>
    
    			<div id="nav-below" class="navigation">
                    //this is the important bit
                    <?php if(function_exists('wp_page_numbers')) { ?>
                    <?php wp_page_numbers(); ?>
                    <?php } else { ?>
    
    				<div class="nav-previous"><?php next_posts_link(__('<span class="meta-nav">&laquo</span> Older posts', 'thematic')) ?></div>
    				<div class="nav-next"><?php previous_posts_link(__('Newer posts <span class="meta-nav">&raquo</span>', 'thematic')) ?></div>
    
    				<?php } ?>
    			</div>	
    
    <?php
    		}
    }
    add_action('thematic_navigation_below', 'childtheme_nav_below', 2);

    Then add this to you style.css to remove the "old posts" text:

    /* =Navigation -- */
    
    .nav-previous {
    display:none;}
    
    .nav-next {
    display:none;}

    Big thanks ap0019er and Method. Like I said, I take no credit for this, just wanted to make it a bit easier to find.

    WP PAGE NUMBERS- http://wordpress.org/extend/plugins/wp-page-numbers/

    Posted 9 years ago #
  2. Thanks for the code!!! I have added it and it is working --> but sadly not with my category pages. There I can only see the first page and when I click on page 2 it will not be found.

    What have I done wrong??

    Hope you can help me.

    Greetings
    Moritz

    Posted 9 years ago #
  3. It s working now!!

    Posted 9 years ago #
  4. Bluesky
    Member

    Thank you for sharing ! It works like a Charm :-))

    Posted 9 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.