ThemeShaper Forums » Thematic

[closed]

Video not embedding

(7 posts)
  • Started 11 years ago by Brad
  • Latest reply from ebswift
  • This topic is resolved
  1. Hi, using the latest version of Thematic and videos (from Youtube) do not seem to embed within the post when I use wordpress's "insert video" tool. It simply creates a link to the youtube page. Does this normally happen with thematic, and is there a way to overcome it? Thanks.

    Posted 11 years ago #
  2. Hi,

    you need to run WordPress 2.9.x. Switch on 'Auto-embeds' in Settings / Media and drop the Youtube link in your post or wrap the link into [embed] link [/embed].

    Chris

    Posted 11 years ago #
  3. Thanks, resolved.

    Posted 11 years ago #
  4. moodle
    Member

    Hi there,

    I have been having the same problem with the Child Theme Neutica+ but have tried all of the above and it still doesnt seem to work.

    I read on another forum that I may need a plugin so I installed and activated the Wordpress Video Plugin but still no video in my blog, only a link through... Would anyone be able to assist? Thanks

    Posted 11 years ago #
  5. I had the same issue -

    2 Custom Child-themes of Thematic -

    Paste YouTube URL into the Visual editor, no embed - just a big space where it should be.
    Installed Viper's Video Quicktags - nothing.
    Checked that the javascript for Viper's was working - nada.
    Checked that the theme called wp_head and the_content and that the javascript for Viper's was in the source when viewing the page - still no video.
    Tried a bunch of other stuff, including disabling all plugins and the functions file - nope.
    Switched to the Kubrick theme - video embeds work!
    Checked to see if under Settings --> Media the "attempt to auto-embed" checkbox was marked/on - yup.

    Then I noticed that under Settings --> Media the Maximum Embed size for Width was empty (height did have a number in it). Filled it in with a number - and BINGO!

    Anyone have any idea as to what in the Thematic theme or child-theme could be preventing the video to embed if a Max Width value is not declared?

    Posted 11 years ago #
  6. moodle
    Member

    Hi Cas, Thanks for that. I tried to make adjustments to the media maximum embed size and still no joy.. hmm..
    Could it be my child theme?

    Posted 11 years ago #
  7. I had trouble for a bit, but Chris's instructions did work. It's just that the [embed] code must be placed in HTML edit mode.

    Posted 9 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.