ThemeShaper Forums » Thematic

Warning on childtheme, no such file or directory

(7 posts)
  • Started 5 years ago by Jamie Mitchell
  • Latest reply from Chris
  • This topic is resolved
  1. Jamie Mitchell
    Member

    hey all...

    i keep getting this on the child theme that comes with thematic when i go and select it in WP admin...

    xxxxx is the database, i did not post the DB name on here.,

    Warning: file(/home/xxxxx/public_html/wordpress/wp-content/themes
    /thematicsamplechildtheme/style.css) [function.file]: failed to open stream: No such
     file or directory in /home/xxxxx/public_html/wordpress/wp-includes/theme.php on
     line 180
    
    Warning: implode() [function.implode]: Invalid arguments passed in /home/xxxxx
    /public_html/wordpress/wp-includes/theme.php on line 180

    now i have build a handful of child themes and have only just started getting this with V0.9.

    When i view the childtheme, there is no stylesheet loaded, and the warning is at the top. i have not done anything to the theme, it is fresh out of the box. and a new installation of WP (on a friends site), although i was having the same problem on my own site. even when i start adding my own style to the child theme, or even renaming it, it's still there.

    if i select the thematic theme itself in the WP admin, it's fine, it's only the child themes.

    any suggestions appreciated.

    Posted 5 years ago #
  2. Hey Jamie,

    sorry.. just a couple of things to check:

    - Is style.css exisiting?
    - Check file attributes (644)
    - Check if style.css is consistent
    - copy child theme once again to the server

    theme.php tries to open style.css and read it into a string .. opening or reading the file fails and therefore implode fails too.

    Cheers,

    Chris

    Posted 5 years ago #
  3. Jamie Mitchell
    Member

    Hey Chris !!

    could not figure it out...

    but what i ended up doing was linking the styles for the child them with just

    @import url('../thematic/style.css');

    instead of the

    /* Reset browser defaults */
    @import url('../thematic/library/styles/reset.css');
    
    /* Apply basic typography styles */
    @import url('../thematic/library/styles/typography.css');
    
    /* Apply a basic layout */
    @import url('../thematic/library/layouts/2c-l-fixed.css');
    
    /* Apply basic image styles */
    @import url('../thematic/library/styles/images.css');
    
    /* Apply default theme styles and colors */
    @import url('../thematic/library/styles/default.css');
    
    /* Prepare theme for plugins */
    @import url('../thematic/library/styles/plugins.css');

    which was in the sample child theme.

    all seems ok....weird

    cheers..j

    Posted 5 years ago #
  4. Nate
    Member

    I am getting this same error. Changing the style sheet linking to just @import url('../thematic/style.css'); makes no difference. I tried Chris's suggestions to no avail. Changing "Template: thematic" to "Template: classic" removes the error, but of course I am wanting to use Thematic as the parent theme.

    I am using Thematic 0.9. Any suggestions?

    Posted 5 years ago #
  5. Hey Nate,

    please drop me an email chris (at) wupperpiraten (dot) de

    Will send you my basic themes working at my provider.

    If this doesn't work .. is it possible to setup an additional ftp account and admin account for me so that I can check what's going on on your web space / server?

    Cheers,

    Chris

    Posted 5 years ago #
  6. Nate
    Member

    Thanks for going out of your way to help, Chris!

    In my case the error was due to a hyphen in the folder name for the child theme. I took out the hyphen and everything started working. From "my-theme" to "mytheme".

    Posted 5 years ago #
  7. Thanks a lot for this info, Nate! .. I changed the directory name in our SVN repository.

    Cheers,

    Chris

    Posted 5 years ago #

RSS feed for this topic

Reply

You must log in to post.