ThemeShaper Forums » ThemeShaper WordPress Themes

Wooo it's working but one problem...

(11 posts)
  • Started 11 years ago by waseem
  • Latest reply from waseem
  • This topic is resolved
  1. Here check it out http://socoba.org
    But I have one problem. I can't login to the admin dashboard. The problem is with the functions.php of my childtheme because when I delete it I can perfectly Login. Do you have any ideas to why this is happening, the php is working and i'm not getting any white screen of death so idk what it is.

    Posted 11 years ago #
  2. What do you got in that there template file?

    Posted 11 years ago #
  3. im actually upgrading to 2.6.1 ill reupload everything soon so you can check out the new design.

    Posted 11 years ago #
  4. Ok so I upgraded to 2.6.1 but still having the problem. I cant access the admin panel It just shows a white screen, but the website is showing perfectly fine. very weird.

    Posted 11 years ago #
  5. But what do you have in your functions file?

    Posted 11 years ago #
  6. Here is what I have in the functions below my navbar function

    <?php
    function secondary_header() {
    ?>
    
    <?php if ( is_home() ) { ?>
    
    <div id="homeframe">
    <span>1</span>
    
    <div id="headleft">
    <div id="homeinfo">
    <li id="whatis">Donate</li>
    <p>Socoba is a non-profit organization that is dedicated to improving the lives of children orphaned by HIV/AIDS. Currently Socoba is working in Mabule, Botswana to create a day care center for the children.</p>
    </div>
    
    <div id="learnmenu">
    <ul>
    	<li id="learnmore"><a href="<?php echo get_option('home') ?>/about" title="Learn More">Learn More<em></em></a></li>
    
    	<li id="advocate"><a href="<?php echo get_option('home') ?>/advocate"title="Advocate">Advocate<em></em></a></li>
    
        <li id="mdonate"><a href="<?php echo get_option('home') ?>/donate" title="Donate">Donate<em></em></a></li>
    </ul>
    </div>
    </div>
    
    <div id="headright">
    <div id="latestnews">
    <li id="newshead">Latest News</li>
    <?php include (ABSPATH . '/wp-content/plugins/content-gallery/gallery.php'); ?>
    </div>
    
    <div id="businesslink">
    <ul id="buslink">
    	<li id="buslink_1"><a href="<?php echo get_option('home') ?>/business"><span>Business</span></a></li>
    </ul>
    </div>
    </div>
    </div>
    
    <?php }
    
    ?>
    
    <?php }
    
    add_action('thematic_belowheader','secondary_header');
    ?>
    Posted 11 years ago #
  7. Drop the PHP tags around your functions and actions. Your functions file should start with "<?php" and end with "?>" and not include any PHP tags in between. Unless you're doing something like this:

    function sample_function() { ?> /* this interupts the big PHP function that is functions.php*/
      <?php echo 'Here's a sample function'; ?>
    <?php } /* … and this starts it back up again */
    Posted 11 years ago #
  8. so if I remove the php tags will it continue to work? I'm not really understanding what you are saying.So the only correct way to write the function is writing it like this

    <?php echo 'Here's a sample function'; ?>
    Posted 11 years ago #
  9. hmmmm if i remove all the php tags inbetween everything on the site stops working and I get the white screen =( is there a way to load an external php file in to the functions.php that way I can make it sure it only starts with <?php and ends with ?>

    Posted 11 years ago #
  10. Email me the functions.php file. I'll see if I can take a look. ian at my domain.

    Posted 11 years ago #
  11. thanks!
    I sent you the php file.

    Posted 11 years ago #

RSS feed for this topic

Reply

You must log in to post.