ThemeShaper Forums » Thematic

WordPress 2.8

(9 posts)
  • Started 4 years ago by Chris
  • Latest reply from Chris
  • This topic is not a support question
  1. Hi Thematicians,

    sorry for not answering as promised but WordPress v2.8 is keeping me busy.

    It seems as if WP 2.8 has a couple of issues which I'm currently investigating.

    Please stay tuned and wait for further news.

    Cheers,

    Chris

    Posted 4 years ago #
  2. The get_categories() issue is pretty weird. Works in a regular theme file, works in the functions.php used as an action hooked to a regular theme file, but doesn't work at all as soon as I'm trying to get the data out of it ..

    Posted 4 years ago #
  3. Ok .. got it .. In 2.8 the creation of default taxonomies moved into a function (create_initial_taxonomies) that is run by the "init" action hook .. that's the thing that caused my headaches.

    Knowing this, it's pretty easy to provide a fix for the Acamas Option Page.

    Posted 4 years ago #
  4. What was the next issue to be solved? .. was something 'bout jQuery .. do I need some more Aspirin or do I need a beer?? .. will decide later :-)

    Posted 4 years ago #
  5. jQuery? .. one problem occurs, if you swap the current version against a newer one. To prevent all kind of weird problems in wp-admin, you should use this code:

    function override_jquery() {
         if ( is_admin() ) // using a newer version of jQuery will break stuff in WP admin
              return;
         wp_deregister_script('jquery');
         wp_register_script('jquery', '/path/to/your/version/of/jquery.js');
    }
    
    add_action('init', 'override_jquery');
    Posted 4 years ago #
  6. .. do we have more jQuery? .. think so ..

    Posted 4 years ago #
  7. amygail
    Member

    Thanks for the jQuery tip - that's going to save me a serious headache.

    I'd go for beer AND asprin......

    Posted 4 years ago #
  8. .. decided to go for beer .. don't think that I'll need the aspirin :-)

    Posted 4 years ago #
  9. The issue with the Acamas options page was caused by a bug in 2.8. This one is already fixed in the nightly build of WP 2.8.1.

    I integrated a workaround into Acamas. The backend will now work with WP 2.8.

    Cheers,

    Chris

    Posted 4 years ago #

RSS feed for this topic

Reply

You must log in to post.