ThemeShaper Forums » Thematic


Wordpress 404 not being called

(6 posts)
  • Started 10 years ago by Mike_sa
  • Latest reply from Mike_sa
  • This topic is resolved
  1. Hi

    I am having an issue with the default 404.php file not being called.
    I am using the thematic theme and have created a child theme. I have also added the 404.php to the child theme when it did not work.

    From looking at the 404.php file I have deducted that it should already be calling my header, side bar and footer.

    It looks as though the 404 that is being called is the standard 404 called by my server if a file does not exist.

    the working site url :

    404 url I have been using to test 404 ;

    I am not sure why thematic is not automatically calling the default wordpress 404 or the thematic 404.

    Has anyone else ever experienced this before?

    Posted 10 years ago #
  2. I set my permalinks and all is working

    Posted 10 years ago #
  3. AnotherAndrew

    What did you specifically do to fix this?

    I am having some problems too.

    Posted 10 years ago #
  4. Hi AnotherAndrew

    In the sidebar in the wordpress cpanel I selected the custom permalink structure, entered the desired permalink.

    Saved and all started working :)

    Hope this helps

    Posted 10 years ago #
  5. Hi! I am having a similar problem and I'm not sure how to fix it.

    I am using a child theme for Thematic. I am using the custom permalink setting /%year%/%monthnum%/%postname%/. For some reason, when you scroll down and click "older posts" I get a 404 page.

    I am using 1and1 and my mod_rewrite is on, I don't know why this is happening.

    I've tried-

    deleting my htcassess, disabling all my plugins, changing the custom permalink settings to include %post_id%, every single plugin that exists, changing my reading settings.

    do i have to change it to match my reading settings which are 5 posts per page?

    the code in my blog template is

    $wp_query = new WP_Query();
    $wp_query->query( array( 'posts_per_page' => get_option( 'posts_per_page' ), 'paged' => $paged ) );
    $more = 0;

    please help!! I'd be so thankful!

    Posted 10 years ago #
  6. Hi Jenn

    Can you please list the url.

    I may be able to help you then


    Posted 10 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.