ThemeShaper Forums » Thematic

EasySlider and Thematic

(5 posts)
  • Started 12 years ago by killtheliterate
  • Latest reply from jbtank
  • This topic is resolved
  1. Redesigning my blog, placing a slideshow I created into the new design. Worked in the old one. It's called EasySlider, and relies on jquery.

    I placed the JS inline in the header of my child theme, but it won't load. After reloading the page using firebug, I see an error that says:

    $(document).ready is not a function

    I'm not very familiar with scripting, and don't know what to do here...

    Posted 12 years ago #
  2. amygail

    There may be someone better to answer this..

    It looks like you need to change the script to work in no conflict mode.
    A quick and (usually) simple fix is to change all the '$' to 'jQuery'

    Try that - but do read this...

    good luck

    Posted 12 years ago #
  3. thank you! very much!

    I just got it working, thanks to you, by changing the "$" in the script to "jQuery"
    still loading the src script inline right above it... might make it load as a function later, but right now, i just want to see it work...

    you are rad

    Posted 12 years ago #
  4. amygail

    cool -glad it worked for you!
    FYI - one thing that has really helped me is to google the error messages that firebug gives me

    Posted 12 years ago #
  5. jbtank

    I found this article, which I believe addresses your JQuery in Wordpress problem:

    Posted 11 years ago #

RSS feed for this topic


You must log in to post.