ThemeShaper Forums » Thematic


errors activating child theme

(2 posts)
  • Started 11 years ago by krowchuk
  • Latest reply from krowchuk
  • This topic is resolved
  1. Hi,

    I decided I was ready to test my child theme on my server, so I set up a new subdomain, installed a fresh wordpress install and imported my content over. All was well with the 2010 theme, so I grabbed a copy of Thematic from the Dashboard install themes. That worked fine, however, when I uploaded my child theme and went to activate it I ran into problems.

    I received some errors to do with php and headers can't be loaded. Sorry, I didn't take notes on those errors. It did lock me out of wordpress completely so I could not even log into dashboard. Since it was a test site I decided just to delete the install and start over. Again 2010 and Thematic work great, but my child theme is creating errors. This time I decided to "preview" before activating.

    Here is the error I receive in the preview window:

    Warning: fopen(/home1/krowchuk/public_html/test/blog/wp-content/themes/wicked2/style.css) [function.fopen]: failed to open stream: No such file or directory in /home1/krowchuk/public_html/test/blog/wp-includes/functions.php on line 4165
    Warning: fread(): supplied argument is not a valid stream resource in /home1/krowchuk/public_html/test/blog/wp-includes/functions.php on line 4168
    Warning: fclose(): supplied argument is not a valid stream resource in /home1/krowchuk/public_html/test/blog/wp-includes/functions.php on line 4171

    So, I created a blank child theme thinking maybe there was something in my functions file causing this. I stripped out all of my added functions but still get the same error message. Next I stripped out my css changes (left in the bare necessities) and I still get the same error.

    Anyone have any ideas?


    Posted 11 years ago #
  2. I have resolved this issue by creating a blank child theme using the sample provided and started to add in my custom functions and css, checking the "preview" as I made additions. It remains a mystery to me as to what was causing the error, but it is fine now.

    Although it remains a mystery, I am sure it was something I was doing and it is resolved.

    Posted 11 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.