ThemeShaper Forums » Thematic


Issue with Child Theme Options Page & wp-admin panel on LOCAL host

(4 posts)
  • Started 11 years ago by kgoodman
  • Latest reply from tarpontech
  • This topic is not resolved
  1. kgoodman

    I am unable to access wp-admin on my LOCAL host when I have enabled the Child Theme Options. Oddly enough, I do NOT have this issue in Production.

    I've narrowed down the issue to the Child Theme Options page code found here but can't figure out how to resolve it or even WHY it is happening since again, it's completely fine in Production.

    Thematic Feature Site Child Theme
    MAMP local host
    Wordpress version 2.9.1

    The following issues apply only to my LOCAL host:
    1) I added the code for adding a Child Theme Options Page found here to the end of my functions.php. Worked great, until I had to relaunch my browser.

    2) When I relaunched my browser and tried to access wp-admin on my LOCAL host, I get a blank page; a white screen, no error message, nothing.

    3) If I remove the code for the child theme options page from functions.php and then try to access wp-admin, I can then log in without problems.

    4) As a test, I activated the Commune 0.4 child theme which comes out of the box with code for the child theme options page. Oddly, I do not run into this issue. E.g. the wp-admin file remains accessible whenever I relaunch my browser or restart my local server.

    I'm stumped as to why adding the child page options page code to my functions.php for the feature site child theme would make the wp-admin panel disappear on my local host. And to even make it more strange, I don't encounter the same problem on my production server.

    And in answer to some inevitable questions:
    A. Yes, I completed the list of wp-admin troubleshooting tips on the codex. Did not work.
    B. Yes, I confirmed dev and prod environments match.
    C. Yes, I have deleted and recreated the DBs.
    D. Yes, I've even reinstalled MAMP.
    E. Yes, I verified there weren't any extra spaces, lines or code at the end of my functions.php (either with or without the child theme options code)
    F. Yes, the issue exists across browsers.

    The workaround trying to access wp-admin on my local host is cumbersome and time consuming. And as much as I'd love to leave my browser live at all times, there are moments when I have to reboot.

    Any help/thoughts/suggestions are greatly welcome. I've been working on this for the last two days.

    Thanks so much,

    Posted 11 years ago #
  2. Hi-

    Have you tried to turn error logging on in your config file? There are instructions in the codex on how to do it.

    extremely helpful at times like what your describing.


    Posted 11 years ago #
  3. zsigmonda

    I'm having the exact same problem. KN - did you ever find a solution?
    Many thanks for any advice.

    Posted 10 years ago #
  4. as this sort of thing happens to me 10 times a day as a non php-coder, and I've had this exact problem when using this logo-changing code, I can tell you that most likely you're missing a closing bracket semi-colon or php closing tag somewhere. When everything goes white, it means you're running a broken script.

    I've since made the switch to using notepad++, (thanks Helga!), and it makes tracking down missing syntax much easier. 5 bucks says you need a ' or ", (), or most likely a {} or ; somewhere.

    Also make certain you have no extra lines in your functions.php after the closing ?> , that one gets me too.

    The code from cozmolabs is good, its our implementation at issue...

    My final piece of advice, when dealing with pretty large blocks of code like Cristian's header-logo code, is to stick it in a separate php file, and use a include in functions.php to load up the script. Makes isolating, finding, and fixing errors much easier when things are modular.

    Posted 10 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.